Partial Transfer Problem

lists at lists at
Thu Aug 21 18:05:00 GMT 2008

I am using the command options listed below.  If I set --partial or --partial-dir, I see the partial file appear as expected.  However, even with --partial-dir set as you see below, the .rsync-partial directory is never created.  Instead the partial file just appears in the directory.  The bigger problem is that if I interrupt the transfer and then restart it some time later, rsync just creates a new partial file from the beginning.  I have even tried stopping the daemon on the other end and restarting it.  It doesn't use the already existing partial file at all, no matter what I have tried.

The strange thing is that this only occurs on downloads.  If I use the same settings as below only I change the source and destination around, both --partial and --partial-dir work as expected.  My rsync version is 3.0.3.  What am I doing wrong?

"C:\Program Files\cwRsyncServer\bin\rsync.exe" ^
--max-size=75m-1 ^
--recursive ^
--times ^
--partial-dir=.rsync-partial ^
--timeout=160 ^
--contimeout=160 ^
--log-file=./rsync.log ^
--delete ^
--include=*.zip ^
--exclude=/*.* ^
--progress ^ ^

Thank you in advance.

- Kyle

More information about the rsync mailing list