rsync hangs when accessing through SSH (Leopard OS X)

Greg Loesch gloesch.web at
Sat Dec 8 16:36:40 GMT 2007

Alexandros Papadopoulos wrote:
> On Sunday 02 December 2007 22:39, Greg Loesch wrote:
>> To preface, I'm running Leopard OSX and am using rsync  version 2.6.9
>> protocol version 29.
>> Whenever I attempt to sync (using rsync obviously) a folder on my
>> local drive to my web server ( is my web host) using SSH,
>> the process hangs. I have to force kill it in order to continue using
>> Terminal. I can connect to my server space using SSH just fine by
>> itself, and I ran rsync to sync two folders locally just fine. Is
>> there some special syntax I need to use when using rsync with SSH?
>> I've searched google and the mailing lists, and I didn't find much.
>> I'm fairly inexperienced with Unix, so I believe that I am the culprit
>> of this problem :-)
>> This is the syntax I'm using:
>> 'rsync -avz /iWeb/test [username]'
> 1. Is rsync installed on the machine you're transferring stuff to?
> 2. Assuming the destination folder TEST is in your home directory on the 
> target server, try the syntax:
> rsync -avvz -e "ssh -v" /iWeb/test [username]
Note: I updated to the newer version of rsync

1. I'm not sure if it's installed on the machine I'm transferring to or not.
It's a webhost, so is there a way to know? Is it that simple? Am I just...
an idiot and didn't realize it needs to be installed on both ends?

2. I tried what you suggested and this is what I got (sparing you seemingly
unneeded info). If you need more info just let me know.

debug1: Authentications that can continue: password
debug1: Next authentication method: password
[username]'s password: 
debug1: Authentication succeeded (password).
debug1: channel 0: new [client-session]
debug1: Entering interactive session.
debug1: Sending command: rsync --server -vvlogDtprze30.15i . ~/test
debug1: client_input_channel_req: channel 0 rtype keepalive at
reply 1
debug1: client_input_channel_req: channel 0 rtype keepalive at
reply 1

//And it repeats this until I kill the process with ^C. Then it says:

debug1: channel 0: free: client-session, nchannels 1
debug1: fd 0 clearing O_NONBLOCK
debug1: fd 1 clearing O_NONBLOCK
Killed by signal 2.
rsync error: unexplained error (code 255) at rsync.c(502) [sender=3.0.0pre6]

View this message in context:
Sent from the Samba - rsync mailing list archive at

More information about the rsync mailing list