copying directory structure only (not the files) from a remote UNIX box using rsync

Matt McCutchen hashproduct+rsync at
Fri Apr 27 00:50:06 GMT 2007

On 4/25/07, Tariq Shaikh <tariq.a.shaikh at> wrote:
> Hi,
> I am trying to copy the directory structure only from the remote UNIX
> box onto the box from which Im executing the rsync.
> This is what I tried:
> rsync -av --include '*/' --exclude '*' tashaikh at remotebox:/dw/etl/
> home/
> prod/log/ /export/home/tashaikh/auto/log
> The above keeps on executing without returning any result.
> I have tried to copy directory structure from another directory on the
> same machine itself . The one shown below works:
> rsync -av --include '*/' --exclude '*' srcdir/ destdir
> Please let me know if Im doing anything wrong while doing it with a
> remote UNIX box.

Three suggestions for debugging the remote command:

(1) Use more -v options.

(2) I really doubt the include/exclude options are causing the
problem.  Try the command without those options and see if it hangs in
the same way.

(3) You didn't mention what version of rsync you're using.  If either
side is older than 2.6.9, try upgrading to 2.6.9.


More information about the rsync mailing list