Rsync problem

James Sewell james.sewell at
Sun Mar 2 09:51:39 EST 2003


I just fixed this problem by adding -T /tmp.

I find this odd, as the files I am moving have a combined size of 
115852000 bytes, the file system they reside on (I was also running the 
command from this filesystem) has 68077044000 bytes free - so it is not 
a free space issue. I can copy one file out of the directory by itself 
with rsync so it is not a perms issue either.

I am stumped as to whats up, but at least I am fixed now!


James Sewell wrote:

> Hey All,
> I am running rsync  version 2.5.5  protocol version 26 on my remote 
> machine (Redhat 8 def. install) and rsync  version 2.5.6  protocol 
> version 26 on my local machine (Redhat 7.2,  2.4.17 kernel instead of 
> Redhat one with acl patches). I can copy files between these two 
> machines (using ssh/scp) fine.
> When i run the command:
> rsync  -rptz --delete --stats --include="*.ini" --include="*.csv" 
> --include "*/" --exclude "*" --rsync-path=/usr/bin/rsync 
> /directory/data remotehost:~datawh/datawarehouse
> I get this output:
> rsync: writefd_unbuffered failed to write 9779 bytes: phase "unknown": 
> Broken pipe
> rsync error: error in rsync protocol data stream (code 12) at io.c(515)
> Rsync exits with an error code of 12.
> The data in the /directory/data/ folder is all able to be accessed by 
> the user I run as, as is the remote dir. It is not a persmissions 
> thing as some data does go across before the problem (and i can just 
> copy the data if I want to with scp).
> The file in the /directory/data folder are all plain ASCII files (.csv 
> and .ini files obviously). Unfortunatley I don't think I can post any 
> peices of the files due to commercially sensitive content.
> I have another directory called /directory/data2 which has the same 
> files, with information for a different organisation in it. This 
> directory works fine.
> Any hints.. .. .. anything?
> Thanks,
> James

More information about the rsync mailing list