Orphaned rsync process on remote machine?

Marc Sarrel Marc.A.Sarrel at jpl.nasa.gov
Tue Dec 23 12:45:41 EST 2003


Sometimes when I do an rsync, it times out and leaves on orphaned 
process on the remote machine.  I am running rsync over ssh using 
public key authentication.  I synchronize about twenty-five machines, 
and this problem only appears on one of them.  It worked until 
recently on this machine.  I don't know what changed or what is 

I run rsync with a command line like this (only the names have been 
changed to protect the innocent) :-):

>aaaaaa:msarrel /u/cas/msarrel 105> /usr/local/bin/rsync --verbose 
>--checksum --recursive --copy-unsafe-links --times --rsh=ssh 
>--rsync-path=/usr/local/bin/rsync --delete --timeout=90 
>--ignore-times --compress /lll/mmmmmmmmm/ 
>bbbbbbb at cccccccc.dddddd.eee.ffff.ggg:/hhhh/iii/jjjjj/kkkkkkkkk
>building file list ... done
>io timeout after 90 seconds - exiting
>rsync error: timeout in data send/receive (code 30) at io.c(103)
>aaaaaa:msarrel /u/cas/msarrel 106>

I tried changing the timeout to be 300 seconds, but got the same 
result.  To this particular machine, the packets actually take a 
fairly tortured route.  They go from the source, out through a 
firewall, into a VPN tunnel, across the Internet, in through another 
firewall, out of the VPN tunnel, over the river, through the woods, 
to grandmother's house and finally to the destination machine. 
However, there is a second machine at the same site that works with 
the same tortured route.

The orphaned process on the remote machine looks like this:

>  8 R    msarrel 12023 12017 99  99 20 739adbf0    471 
>01:25:32 ?        2:44 /usr/local/bin/rsync --server
>  8 S    msarrel 12017     1  0  40 20 739a8740    325 739e6d46 
>01:25:32 ?        0:00 tcsh -c /usr/local/bin/rsync

I'm using the following version of rsync:

>rsync  version 2.5.6  protocol version 26
>Copyright (C) 1996-2002 by Andrew Tridgell and others
>Capabilities: 64-bit files, socketpairs, hard links, symlinks, batchfiles,
>               no IPv6, 64-bit system inums, 64-bit internal inums
>rsync comes with ABSOLUTELY NO WARRANTY.  This is free software, and you
>are welcome to redistribute it under certain conditions.  See the GNU
>General Public Licence for details.


Distributed Operations Coordinator  | IO GDS System Engineer
(Operations - Marc and Pam)         | (Development - Marc)
+1 818 393-7840 (voice)             | +1 818 393-7786 (voice)
+1 818 393-4669 (fax)               | +1 818 393-4669 (fax)
mailto:doc at cdsa.jpl.nasa.gov        | mailto:Marc.A.Sarrel at jpl.nasa.gov
+1 800 759-8888 PIN 2028873 (pager) | +1 800 759-8888 PIN 5877194 (pager)
mailto:2028873 at skymail.com (pager)  | mailto:5877194 at skymail.com (pager)

Pager web message:
http://www.skytel.com/servlet/SendMessage?pin=2028873&pageme=yes (DOC's pager)
http://www.skytel.com/servlet/SendMessage?pin=5877194&pageme=yes (Marc's pager)

https://cassini.jpl.nasa.gov/csos/io (IO home page)

Jet Propulsion Laboratory
4800 Oak Grove Dr
M/S 230-250
Pasadena, CA  91109-8099

More information about the rsync mailing list