Permissions Problems Problem solved!

John Davis johnd at
Tue Dec 23 09:46:44 EST 2003

I had forgotten to set the permissions on the upload folder on the
remote server. Once I set the perms correctly, it worked. Thanks to
everyone for the help!

-----Original Message-----

Here's my command copied from a shell script:\

rsync --verbose  --progress --stats --compress --rsh=/usr/bin/ssh
--recursive --times --perms --links \
/home/* trt at

Here's some (a small part) of the output:
         253 100%    0.00kB/s    0:00:00
rsync: recv_generator: mkdir "jk/.secpanel/.runfiles": Permission denied
(2) stat jk/.secpanel/.runfiles : Permission denied
rsync: failed to open "jk/.viminfo", continuing : Permission denied
        4503 100%    0.00kB/s    0:00:00
rsync: recv_generator: mkdir "jk/Desktop/Trash": Permission denied (2)
stat jk/Desktop/Trash : Permission denied jk/
         161 100%    0.00kB/s    0:00:00
mkstemp jk/..bash_history.zb2Vlp failed: Permission denied mkstemp
jk/..fonts.cache-1.WRbevE failed: Permission denied mkstemp
jk/..recently-used.rleTG4 failed: Permission denied mkstemp
jk/..viminfo.IcFUcX failed: Permission denied mkstemp
jk/ failed: Permission denied rsync[17002] (sender) heap
  arena:        1659224   (bytes from sbrk)
  ordblks:           51   (chunks not in use)
  smblks:             6
  hblks:              1   (chunks from mmap)
  hblkhd:        266240   (bytes from mmap)
  usmblks:            0
  fsmblks:          232
  uordblks:     1509880   (bytes used)
  fordblks:      149344   (bytes free)
  keepcost:      132928   (bytes in releasable chunk)

The script is being run from the root account. My understanding is that
running as root will eliminate the permission errors, but apparently
that's not so. 

More information about the rsync mailing list