Update to Current Issues; http://rsync.samba.org/issues.html

Erik Enge eenge at prium.net
Fri Sep 27 18:45:01 EST 2002


I read this from the Current Issues:

   1.  Q: Transfers die with something like

       rsync: error writing 4 unbuffered bytes - exiting: Broken pipe
       rsync error: error in rsync protocol data stream (code 12) at ../src/io.c(463)

       A: Sometimes fatal error messages from the remote machine can be
       lost on the way to the client; you should investigate on the
       server for something stopping the transmission. The most common
       cause is that the destination disk is full.

I was able to reproduce this error, but it was not because the disk was
full.  In fact, I only realized what it was when I ran rsync from a
different host (ie. different version of rsync):

  ERROR: module is read only
  rsync error: syntax or usage error (code 1) at main.c(455)
  rsync: connection unexpectedly closed (28 bytes read so far)
  rsync error: error in rsync protocol data stream (code 12) at io.c(150)

Aha!  Adding "read only = false" fixed it.

rsync 2.5.5 did not report this as a read only problem, 2.5.6 did.  If
many people are having this problem, perhaps it would be advisable to
update the current issues.

Erik Enge
Software Engineer
Professional Reviews Inc.

More information about the rsync mailing list