error starting client-server protocol (code 5)

Doug Schasteen dschast at
Fri Sep 6 15:16:00 EST 2002

Ok, I played around with it some more and I found that if I run rsync as
a standalone daemon, it works fine. So it appears the problem I was
having was with inetd, specially my inetd.conf file. I’d still rather
run this thing through inetd so I’m going to keep trying to get this to
work. When I first put my rsync line into inetd.conf I was just
following the instructions in the man pages. But after looking it over,
the line I added is missing something at the end that the rest of the
inetd.conf lines have. Here is a sample taken from my inetd.conf

#shell  stream  tcp     nowait  root    /usr/libexec/rshd       rshd
#login  stream  tcp     nowait  root    /usr/libexec/rlogind    rlogind
#finger stream  tcp     nowait/3/10 nobody /usr/libexec/fingerd fingerd
#exec   stream  tcp     nowait  root    /usr/libexec/rexecd     rexecd
#uucpd  stream  tcp     nowait  root    /usr/libexec/uucpd      uucpd
#nntp   stream  tcp     nowait  usenet  /usr/libexec/nntpd      nntpd

# Added by Doug
rsync  stream  tcp     nowait  root    /usr/local/bin/rsync --daemon

As you can see, the rest of the inetd lines have a “name” or something
after the path/command. The man pages didn’t say to put anything there,
but maybe I should put “rsync” after -–daemon? If that’s not the problem
then I don't know what is.

Here is the contents of my /usr/local/etc/rsynd.conf file just in case.

# rsyncd.conf configuration file


log file=/var/log/rsyncd.log


    path = /www
    use chroot = no
    max connections = 4
    auth users = rsync
    hosts allow =
    read only = yes
    secrets file = /etc/.rs_sec
    uid = nobody
    gid = nogroup
    transfer logging = yes
    dont compress = *.gz *.tgz *.zip *.z *.rpm *.deb *.iso *.bz2 *.tbz

- Doug

-----Original Message-----
From: rsync-admin at [mailto:rsync-admin at]
On Behalf Of Doug Schasteen
Sent: Friday, September 06, 2002 9:10 AM
To: rsync at
Subject: error starting client-server protocol (code 5)

I’m running FreeBSD 4.6.2 on two different machines. Both machines have
rync installed by way of the ports library, but one of them is running
it as a server. I followed the directions in the man pages for running
the server using inetd. 
Here is what happens:
rsync rsync://myusername@
rsync: server sent “rysnc version 2.5.5 protocol version 26” rather than
rsync error: error starting client-server protocol (code 5) at
I get that same error message any way that I try to access the server,
even with a simple “rsync”
Has anyone seen a message like this before? Does it mean that I set
something up wrong? I can post my rsyncd.conf contents if necessary.
- Doug

More information about the rsync mailing list