dir list behavior differences?

tim.conway at philips.com tim.conway at philips.com
Wed Nov 21 02:04:17 EST 2001

You're not crazy.  I've seen similar behaviour.  The trailing / does not 
always (or even usually) bring about the documented behaviour.  I have 
tried to use that before, and had rsync delete most of what i already had, 
even though it exists on the source... it simply doesn't come through. For 
directories with no .files, i use dir/*.  for directories with .files, i 
have to sync the directory itself.  Fortunately, in my application, that's 
not a problem.  It just really bit me in the butt the few times i've tried 
to pull over directory contents.  If I were a better programmer, i'd try 
again to debug it, but i'm not, so i just live with it.

Tim Conway
tim.conway at philips.com
Philips Semiconductor - Longmont TC
1880 Industrial Circle, Suite D
Longmont, CO 80501
Available via SameTime Connect within Philips, n9hmg on AIM
perl -e 'print pack(nnnnnnnnnnnn, 
".\n" '
"There are some who call me.... Tim?"

"Don Fike" <fike at cs.utk.edu>
11/20/2001 07:42 AM

        To:     "Dave Dykstra" <dwd at bell-labs.com>
        cc:     <rsync at lists.samba.org>
        Subject:        RE: dir list behavior differences?

The clients that aren't doing a directory listing are;

rsync version 2.3.1  protocol version 20
rsync version 2.2.1  protocol version 19

The client that works as desired and expected 

rsync version 2.4.6  protocol version 24

I tried adding a trailing / but that didn't
encourage the older versions to do a directory
listing.  Instead I got the response below;

skipping directory /
client: nothing to do

Adding a -r did, but the recursion
returns too much data to be useful. 
I can upgrade the older versions here but my
concern and desire is to support those outside
my department using older clients. 
I am getting the impression that those using
older clients are accustomed to not seeing
a directory listing.  If this is true than
I guess I am content with my setup.  Is there
is another way I can encourage a directory
listing, maybe on the server side.


fike at cs.utk.edu

-----Original Message-----
From: Dave Dykstra [mailto:dwd at bell-labs.com]
Sent: Monday, November 19, 2001 5:47 PM
To: Don Fike
Cc: rsync at lists.samba.org
Subject: Re: dir list behavior differences?

On Mon, Nov 19, 2001 at 03:49:27PM -0500, Don Fike wrote:
> Hello,
> I have set up an anonymous rsync server
> that seems to work as expected.  However
> when I try to access the server from several
> other unix boxes using rsync with a command 
> like this;
> rsync netlib3.cs.utk.edu::netlib/
> I get the motd and then a line that states
> client: nothing to do
> Now I would expect this to give me a directory
> listing.  I do get the directory listing as
> expected when doing the command from the local
> box.  I have tried other servers listed here;
> http://sunsite.dk/info/guides/rsync/rsync-mirroring03.html
> and I get the same results, when using some of my
> clients I just get the motd and the client: nothing
> to do error.
> Is this an issue with backwards compatibility between
> new server and older client communications?
> Is there a way to get the listings as expected for
> all clients?

You don't mention the version numbers, but I believe the issue is yes it 
a matter of client version.  Can you not upgrade the older clients?

- Dave Dykstra

More information about the rsync mailing list