[clug] Debian Installation Fail

Alex Satrapa grail at goldweb.com.au
Thu Oct 13 20:02:45 MDT 2011

I'm having trouble getting my Debian-Installer to work. I'm pretty sure it was working fine a week or so ago, but today I get an error, "The installer failed to download a file from the mirror."

From startup:
 - Chose a language -> English/Australia/en_AU.UTF-8
 - Select a keyboard layout -> Do not configure
 - Detect network hardware
 - Configure the network -> Automatically using DHCP
 - Choose a mirror of the Debian archive
 - Download installer components -> falls over

The error message (with ASCII graphics and colours removed) is:

> [!!] Download installer components
> The installer failed to download a file from the mirror. This may be a problem with your network, or with the mirror. You can choose to retry the download, select a different mirror, or cancel and choose another installation method.
> Downloading a file failed:
>  *Retry
>   Change mirror
>   Cancel

What's confusing me is that it's downloading the Release and Release.gpg files just fine, and with no further requests going through the proxy it's claiming that a download failed. Squid reports:

 … TCP_HIT/200 86027 GET http://ftp.au.debian.org/debian//dists/lenny/Release
 … TCP_HIT/200 1505  GET http://ftp.au.debian.org/debian//dists/lenny/Release.gpg

I've tried every mirror in the list:
 - ftp.au.debian.org
 - mirror.aarnet.edu.au
 - ftp.monash.edu.au
 - ftp.uwa.edu.au
 - mirror.eftel.com
 - (etc)

I get the same error message if I try installing Squeeze.

My Ubuntu Hardy Heron installer works just fine.

Any ideas?

More information about the linux mailing list