[clug] mythtv : WriteAudio: buffer underrun

Paul mylists at wilsononline.id.au
Sat Dec 19 21:14:24 MST 2009

  I'm stumped I was monitoring the CPU (AMD 3200+) and its sitting around 5-20% so no 
probs there, memory ok too (I have 2Gb RAM ), MythTV is running with Realtime priority
So it beats me why just CD-Audio is a problem, normal MP3 playback is fine.

Note I ran Gnome Mplayer and it runs without any issue, so just a MythTV problem


On 20/12/2009 12:26 PM, steve jenkin wrote:
> Paul wrote on 20/12/09 8:04 AM:
>> Hi,
>>      Looking for some advise on how to verify my audio setup on MythTV is
>> 100% ok.
>> Note I've been running a Mythbox for at least 3 years on various
>> versions of Fedora , currently F10.
>> I've been struck with these alot this past few months.
>> but now I tried to play an audio CD using MythTV which I don't normally
>> do, but none-the-less it still works but the audio start pausing
>> outputing these msgs
>> WriteAudio: buffer underrun
>> what the heck does this mean, and how do I fix it?
> Paul,
> I've no idea about Myth and playing audio through linux :-(
> But I know in other contexts with a buffer 'underrun' is:
>   - the buffer source (reader process) wasn't able to keep up
>     with the output. The buffer was emptied.
> This means your box was busy doing other stuff, or if not, doesn't have
> the grunt to play audio (unlikely).
> This could be due, in my naivety not knowledge, to:
> a) not enough CPU cycles
> b) not enough RAM
> c) CPU prioritising other tasks higher than audio
> How to distinguish these?
> Sorry, don't know :-(
> Usual approaches are rebooting (to untangle memory pools), increasing
> debug levels and looking in logs, stopping/pausing other tasks.
> First step in any process is being able to reliably reproduce it...
> s
>> any clues anyone?
>> Or can anyone run this test and get playback ok?
>> thanks
>> Paul

More information about the linux mailing list