[clug] Assistance to leave the Bazaar.

Steve Walsh steve at nerdvana.org.au
Sat Apr 29 04:10:14 GMT 2006

I just went through all this and more with the new Toshiba laptop, and ended
up following the instructions at;


If you read carefully through it before you start, you should be fine. I
found I also had to boot into XP recovery mode and run Chkdsk with some
flags before  I could resize it on the toshy, but that was because I hadn't
booted windows to finish the OEM stuff, so ntfsresize was showing it as
"dirty" (ie - not having completed a clean reboot, and not because it was
running XP, which was my original thoughts).

As always, <arse covering> your milage may vary, No warranty implicit or
implied, backup your data, etc etc etc</arse covering>



-----Original Message-----
From: Michael Carden
Sent: Saturday, 29 April 2006 1:13 PM
To: linux at lists.samba.org
Subject: Re: [clug] Assistance to leave the Bazaar.

After sending off my previous post on the subject, I looked across at
XP box and thought back to her positive experiences with the Ubuntu and
Kororaa live CDs. What better time to practise what I preach?

So I took a look at the drive layout and found on the 200G system drive a
drive partitioned as 83G of 'Backup' and never used for more than a gig or
of OEM stuff. So I decided to resize it to 10G or so and set up Ubuntu
Drake flight 6 on the free space.

I also discovered that the Ubuntu Breezy live CD has gparted on it, so
resizing should be easy.

Taking my own advice, I made sure the unused partition was clean and
(it was). I booted the Breezy live CD and brought up gparted. Selected the
near empty partition and resized. Clicked Apply.

No luck. No changes. Hmmm. Thinking to run gparted and also see some error
output, I opened a console window and typed: gparted

Error, need to be root. D'oh, of course. I typed : sudo gparted
..and got on with the job.

Still no changes but some error in the console about /dev/hdc being read
Well, /dev/hdc is the CD drive. It is read only but I'm looking at
changing /dev/hda5 anyway. Odd.

I fiddled for a bit longer (tried several times with no result) then decided
to queue the resize and the reallocate of the free space to ext3 before
hitting Apply. This time it spat an error to the console that suggested I
file a bug report with the gparted folks and no partitions of any type were
visible. I nervously restarted gparted, but nope, no partitions.

Yikes! I've hosed the box. I'm a dead man. With great trepidation I shut
Ubuntu and rebooted.... I have never before been so happy to see that XP
come up. :-)

So... has anyone used gparted to do an ntfs resize? Is there an extra trick?

linux mailing list
linux at lists.samba.org

More information about the linux mailing list