[clug] Whereis Problem

David Tulloh david.tulloh at infaze.com.au
Sat Oct 16 16:34:20 GMT 2004

It looks like you are missing the directory /usr/X11R6/man, which wheris 
Whereis still seems to be working fine, it just posts a warning before 
its standard output.

I found some corrective steps detailed, it sounds similar to what you 
tried, but with the appropriate directory.


Steve Walsh wrote:
> Hi Folks;
> I've hit a screwy one tonight. So far, every package I've installed onto my
> FreeBSD box today causes the following error with whereis;
> %locate nano
> /usr/local/bin/nano
> /usr/local/info/nano.info
> /usr/local/man/cat1/nano.1.gz
> /usr/local/man/man1/nano.1.gz
> /usr/local/man/man5/nanorc.5.gz
> <snip>
> %whereis nano
> Warning: couldn't stat file /usr/X11R6/man!
> nano: /usr/local/bin/nano /usr/local/man/man1/nano.1.gz
> /usr/ports/editors/nano
> Locate can find it, but whereis complains about a missing manfile for an
> unrelated package.
> I've tried the locate database update script at
> /usr/libexec/locate.updatedb, as well as #mtree -U -p /usr/local <
> /etc/mtree/BSD.local.dist both without luck.
> Nano will execute ok, I just get the error when I try a whereis. Only
> problem I've had on the box before this started was a failed make on wget
> due to dependancy issues.
> Anyone got any thoughts?
> Regards
> Steve.

More information about the linux mailing list