Intel Ethernet Express Pro 100 Problems :(

Robert Edwards Robert.Edwards at
Tue Feb 4 11:15:14 EST 2003

I have seen this problem a number of times before. I believe that Intel change 
the PCI ID of the different chipsets they make (which is the correct thing to 

What the driver needs to do is recognise all the current PCI chipset IDs. 
These are in the driver code in drivers/net/eepro100.c in an array called 
eepro100_pci_tbl. You can use lspci to find the PCI IDs for your mobo NIC 
chip and then simply add a line to this array, recompile your modules (if it 
is loaded as a module), install it, run depmod and then modprobe your new 
modified Intel EEPRO 100 module! Voila!


Bob Edwards.

On Thu, 30 Jan 2003 03:22 pm, Andrew Donehue wrote:
> Hi All,
>            I have been using the Intel eepro100 cards for a while now
> (for quality).   I noticed recently with the purchase of a Gigabyte
> motherboard with a built-in eepro100 card that the chipset seems to have
> changed...... The modules that came with the kernel stopped working (I
> was using Turbolinux at this time) - I ended up downloading the latest
> drivers from - and this solved the problem....
> I recently moved to Debian (Woody) - and I found that once again the
> kernel module eepro100.o would not recognise the card.   I tried
> compiling the intel drivers, but got some errors - since then I have
> moved to the 2.4.18-15 kernel (and still getting errors with the intel
> source - saying it wouldn't support "kernels older than 2.4.0" - uname
> -r returns 2.4.18 [weird - I thought it was a 'newer than 2.4.0'
>  kernel....]).
> Anyhow - to get to the point - has anyone else delt with this situation
>  - Any advice would be greatly appreciated :)
> Thanks!
>                Andrew.
> P.S I would like to avoid having to buy a PCI net card as the machine is
> a 1RU rack-mounted server (so trying to have 0 PCI cards).

More information about the linux mailing list