Solaris 8 Nis+ server and RH Linux 7.3 Nis+ client ---- Problems and Questions

ejwensley at ejwensley at
Fri Oct 11 05:30:26 EST 2002

> Date: Wed, 9 Oct 2002 21:19:45 -0700 (PDT)
> From: Ravi Kiran <b_ravi_kiran at>
> Subject: Solaris 8 Nis+ server and RH Linux 7.3 Nis+ client ----
Problems > and Questions
> To: linux-nisplus at
> --0-1068975131-1034223585=:73085
> Content-Type: text/plain; charset=us-ascii
> I have a Solaris 8 which has been serving thin clients which are
> running solaris 8 as well. In a process of making the environment
> heterogenous we are trying to set up Nis+ clients running on RH 7.3. A
> Linux box has been set up as a nis+ client and it does have a nis+
> service. What I mean to say is when I do a niscat on the
> passwd.org_dir I can see the contents. Also when I do a nisstat I see
> that it is binded to the master server and a nisping also replies with
> the master server's name.(There are no replica servers). The automount
> of home directories has not been set up. I did the following on the
> server side to add the credentials of the linux box.
> nisaddcred -p unix.systemname at your.Domain -P systemname.your.Domain.
> des
> nistbladm -a name=groupname host=systemname netgroup.org_dir
> A nisinit has been done on the client side using the nisinit -c -H
> hostname
> A keylogin -r also has been done and the secret key has been stored to
> /etc/.rootkey.
> The client doesnt allow users on the cluster to login.

What do you mean by this? Does it give an error message? Are you logging
in via X windows manager from the console?

I had problems getting NIS+ working. My scenario was this: Login was
through the kdm manager. It seemed to accept the user's name and
password, but then it would just restart X and display the login screen
again. Logging in as root revealed that automount worked, because the
user's home directory had been mounted. Logging in without X, there
quickly flashed a message saying something about the path not being

I needed to make sure that the shell path from the home directory had an
identical path on the local machien. It was looking for my shell in
/usr/local/bin/tcsh. But on my RedHat box tcsh was in /bin. So I created
a soft link to make that happen.

After thinking I had solved my problem, I tried logging in again only to
find the same problems in X and no error messages from the console.
After a long time of troubleshooting, I discovered that some of my login
scripts had paths that could not be resolved. After removing them from
my scripts, problems were solved.

Hope this helps.


More information about the linux-nisplus mailing list