[jcifs] problem with jcifs 1.2.10

Elina Larsson elina.larsson at softhouse.se
Thu Dec 7 15:46:56 GMT 2006

I've downloaded jcifs 1.2.10.jar but this doesn't work.
I use a tomcat server with this configuration in the web.xml (the IPs of the wins property are fake as well as the domain and domain controller properties):

























I would also like to get rid of the IP addresses in the wins property. Is it possible to write the DNS names of the servers here?
At the present we use jcifs 1.2.7. Can I download JCIFS 1.2.8 from anywhere and test if that works better for us?


Från: jcifs-bounces+elina.larsson=softhouse.se at lists.samba.org genom jcifs-request at lists.samba.org
Skickat: to 2006-12-07 13:00
Till: jcifs at lists.samba.org
Ämne: jcifs Digest, Vol 48, Issue 8

Send jcifs mailing list submissions to
        jcifs at lists.samba.org

To subscribe or unsubscribe via the World Wide Web, visit
or, via email, send a message with subject or body 'help' to
        jcifs-request at lists.samba.org

You can reach the person managing the list at
        jcifs-owner at lists.samba.org

When replying, please edit your Subject line so it is more specific
than "Re: Contents of jcifs digest..."

Today's Topics:

   1. NTLMv2 and jCIFS (Adis Katkic)
   2. Re: Websphere+SSO+NTLM (altiuser)
   3. Re: Tests with 1.2.11b / Problems with DFS (Thomas Bley)
   4. Re: NTLMv2 and jCIFS (Eric Glass)


[Message discarded by content filter]

Message: 2
Date: Wed, 6 Dec 2006 15:12:28 +0000 (UTC)
From: altiuser <altiuser_01 at yahoo.com>
Subject: [jcifs] Re: Websphere+SSO+NTLM
To: jcifs at lists.samba.org
Message-ID: <loom.20061206T161010-712 at post.gmane.org>
Content-Type: text/plain; charset=us-ascii

I am stranded, any one out there who can provide some leads, please?


Message: 3
Date: Wed, 06 Dec 2006 19:28:00 +0100
From: Thomas Bley <thomas.bley at simple-groupware.de>
Subject: Re: [jcifs] Tests with 1.2.11b / Problems with DFS
To: James Maupin <james.maupin at metacarta.com>,  jcifs at lists.samba.org
Message-ID: <45770BB0.4070300 at simple-groupware.de>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed


Thanks for your mail. I tried this, but I think the problems come again
if the dfs-link points again to a dfs-link.
The webdisk often uses files[i].listFiles(), so maybe it works when
placing this workaround in the SmbFile Constructor.
But I don't know if this would break the performance ?


James Maupin wrote:
> Thomas,
> Not sure if someone answered you. I found two operations that work only on
> the 'actual' path (as compared to the dfs path): listFiles and opening an
> input stream.
> Try the following:
>        SmbFile file = new SmbFile( "smb://",
> ntlm );
>        if (file.getDFSPath != null) file = new SmbFile(file.getDFSPath());
>        SmbFile[] files = file.listFiles();
>        for( int i = 0; i < files.length; i++ ) {
>            System.out.print( " " + files[i].getName()+"\n" );
>        }
> Not sure if this by design?
> regards,
> James
> -------------------------------------
> James Maupin
> Business Development Engineer, Energy
> MetaCarta, Inc. ( www.metacarta.com )
> 1155 Dairy Ashford
> Suite 201
> Houston, TX 77079
> Tel: (832) 300-8800 USA
> Mob: (832) 746-6802 USA
> james.maupin at metacarta.com
> -----Original Message-----
> From: jcifs-bounces+james.maupin=metacarta.com at lists.samba.org
> [mailto:jcifs-bounces+james.maupin=metacarta.com at lists.samba.org]On
> Behalf Of Thomas Bley
> Sent: Thursday, November 30, 2006 9:39 PM
> To: jcifs at lists.samba.org
> Subject: [jcifs] Tests with 1.2.11b / Problems with DFS
> Hello,
> I've done some tests with the new 1.2.11b and found no problems with
> long/unicode share names and SID resolution / ACEs. It's really great! I
> tested WinXP SP2, W2k3 SP1 and Samba. As soon as I have some time I will
> test a NetApp machine.
> My current problem is a DFS test:
> I have two machines: (w2k3) and (winxp)
> \\\MyRoot\share1 is a dfs share and points to \\\temp
> \\\Temp is a normal share
> When connecting to "share1" and then "Temp", the second one gets "access
> denied".
> When connecting to "Temp" alone, everything is ok, maybe you can help me ?
> Here is my code:
>        NtlmPasswordAuthentication ntlm = new
> NtlmPasswordAuthentication("","administrator","admin");
>        SmbFile file = new SmbFile( "smb://",
> ntlm );
>        SmbFile[] files = file.listFiles();
>        for( int i = 0; i < files.length; i++ ) {
>            System.out.print( " " + files[i].getName()+"\n" );
>        }
>        System.out.println("\n__#second");
>        SmbFile file2 = new SmbFile( "smb://",ntlm );
>        SmbFile[] files2 = file2.listFiles();
>        for( int i = 0; i < files2.length; i++ ) {
>            System.out.print( " " + files2[i].getName() );
>        }
> The problem is the same for the old and the new dfs code in SmbFile.java
> new:
>                    dfsReferral = dr;
>                    request.path = getDfsUncPath0();
> old:
>                    dfsReferral = dr;
>                    unc = dfsReferral.nodepath + unc.substring(
> dfsReferral.path.length() );
>                       if( request.path.charAt( request.path.length() -
> 1 ) == '\\' ) {
>                           request.path = unc + '\\';
>                       } else {
>                           request.path = unc;
>                    }
> Setting a long sleep gives a successful request of "Temp":
>   listfiles: MyRoot/share1
>   Thread.sleep(60000);
>   listfiles: Temp


Message: 4
Date: Wed, 6 Dec 2006 13:22:30 -0500
From: "Eric Glass" <eric.glass at gmail.com>
Subject: Re: [jcifs] NTLMv2 and jCIFS
To: "Adis Katkic" <d97adka at hotmail.com>
Cc: jcifs at lists.samba.org
        <33b41d060612061022w455562f5rbbf732dcbcdfdb8e at mail.gmail.com>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed

There are some specific scenarios where LMv2 will not work properly;
from what I remember:

1) signing will not work if authentication is done with a given
account to a host in a different domain (i.e. user is "DOMAINA\user"
and computer is in DOMAINB).

2) There are issues if you are authenticating against a server that is
configured with the "nolmhash" registry key (it apparently will not
pass the LM response through properly, even though the LM hash is
technically not used in the LMv2 response).

3) There can be issues related to the
NtlmMinClientSec/NtlmMinServerSec registry settings (not necessarily
limited to LMv2).

I had done some related work that I keep meaning to backport in to
jCIFS; as Vista apparently uses NTLMv2/LMv2 by default this may become
a more common issue anyway.  In the meantime, if the server/DC
requires LMCompatibility >= 3 and jCIFS isn't working you might need
to give the specific error messages etc. to diagnose.


On 12/6/06, Adis Katkic <d97adka at hotmail.com> wrote:
> Hi
> I have a problem with jCIFS and NTLMv2.
> I was reading on many places on the Internet about this but I'm still not
> sure if I should give up.
> What I come up to is:
> 1. jCIFS can handle LMv2 which is some kind if NTLMv2 but diffirent length
> of blob or somthing like that.
> 2. This means that jCIFS  may be used with NTLMv2 if server uses Pass Trough
> Authenication?
> Am I right here?
> 3. lmCompability for NtlmHttpFilter must be set to 3.
> However I tried to make it work but it just wouldn't work. I'm not sure if
> my AD uses Pass trough authentication but I suspect it doesn't.
> I can log in from different domain than server domain and if I understood
> well it does not work with Pass trough.
> Any ides how to proceed? Is there some other component out there that could
> help me?
> I found code that Konstantin Kasatkin wrote but I don't know how to use it.
> How about JNDI, is there some components that use JNDI to login via Active
> Directory.
> In my opinion documetation about this issue is quite little.
> I'm thankfull for any kind of help.
> Adis Katkic
> ________________________________
> Express yourself instantly with MSN Messenger! MSN Messenger Download today
> it's FREE!


jcifs mailing list
jcifs at lists.samba.org

End of jcifs Digest, Vol 48, Issue 8

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/ms-tnef
Size: 17922 bytes
Desc: not available
Url : http://lists.samba.org/archive/jcifs/attachments/20061207/942a9321/attachment-0001.bin

More information about the jcifs mailing list