[jcifs] Exception when trying to connect

Mike Mercier mmercier at gmail.com
Tue Apr 25 12:02:19 GMT 2006

Hi All,

The application I used for testing was shown in my original post.

Here it is again:
<start code>
package smbsharetest;
import jcifs.smb.SmbFile;

public class Main {
    public Main() {
    public static void main(String[] args) {
        try {
            SmbFile file = new SmbFile(args[0]);
            String[] fileList = file.list();
            for (int i = 0; i < fileList.length; i++) {
        } catch (Exception e) {
            System.out.println("Got an exception trying to list " + args[0]
+ ":\n" + e);
</end code>

To do the testing I run:
java -jar SmbTestApp.jar smb://<ip address>

I do not attempt to set any of the jcifs properties.  I will have another
look at the machine that does not work, but basically they are ghost images
of one another.  The testing was done by swapping the same ethernet cable
from one box to the other.  I will let you know my results and see what can
be done about supplying a tcpdump of the traffic.


On 4/21/06, Michael B Allen <mba2000 at ioplex.com> wrote:

> So it worked on one machine and not on another? What versions of Java are
> on each machine? That's pretty strange. I believe jCIFS should work with
> Sun's Java 1.3 or above. Maybe there's something odd about the network
> setup on the "old" machine?
> Without a full blown packet capture analysis it's kinda hard for me to
> know what's happening (and even with packet captures it's not guaranteed).
> Are you certain you didn't just fudge the credentials the first time
> (e.g. misspell jcifs.proprties=mimercier.prp etc ...).
> Mike
-------------- next part --------------
HTML attachment scrubbed and removed

More information about the jcifs mailing list