[jcifs] Exception when trying to connect

Michael B Allen mba2000 at ioplex.com
Fri Apr 21 21:22:01 GMT 2006

On Fri, 21 Apr 2006 12:53:04 -0400
"Mike Mercier" <mmercier at gmail.com> wrote:

> Hello,
> I tried your suggestion and used a linux machine to try the following
> command:
> smbclient -L \\\\\\
> I get the results as expected:
> Domain=[Domain] OS=[UNIX] Server=[Samba 2.2.12]
>       Sharename      Type      Comment
>       ---------      ----      -------
>       TESTSHARE      Disk      All Groups
>       IPC$           IPC       IPC Service (Samba Server)
>       ADMIN$         IPC       IPC Service (Samba Server)
> I also tried the application on a different workstation (still Win XP)... it
> worked successfully, but the old workstation still fails.
> Is there something that could be workstation specific that would not allow
> the java to run correctly in certain situations?

So it worked on one machine and not on another? What versions of Java are
on each machine? That's pretty strange. I believe jCIFS should work with
Sun's Java 1.3 or above. Maybe there's something odd about the network
setup on the "old" machine?

Without a full blown packet capture analysis it's kinda hard for me to
know what's happening (and even with packet captures it's not guaranteed).

Are you certain you didn't just fudge the credentials the first time
(e.g. misspell jcifs.proprties=mimercier.prp etc ...).


More information about the jcifs mailing list