[distcc] distcc fails: still in backoff period

Fergus Henderson fergus.henderson at gmail.com
Mon Feb 16 19:54:59 GMT 2009

On Mon, Feb 16, 2009 at 5:24 AM, Daniel Klaffenbach <
danielklaffenbach at gmail.com> wrote:

> Am Montag 16 Februar 2009 10:35:27 schrieb Martin Pool:
> > This still doesn't contain the original message that caused
> > dk.home.local to be disliked.  Clear the relevant file out of the
> > distcc directory and try again.
> I removed all tempoarary build directories and did a
> rm -rf /root/.distcc
> rm -rf /var/tmp/portage/.distcc
> But the log still does not seem to show any relevant information:
> http://www-user.tu-chemnitz.de/~klada/misc/webkit-build2.log<http://www-user.tu-chemnitz.de/%7Eklada/misc/webkit-build2.log>

Maybe distcc is being invoked during the configuration steps shown in that
log, with the output redirected somewhere else.

This is the content of /var/tmp/portage/.distcc/lock/ after the build:
> laptop ~ # ls /var/tmp/portage/.distcc/lock/
> backoff_tcp_dk.home.local_3632_0  cpu_localhost_0  cpu_localhost_1
> cpu_tcp_dk.home.local_3632_0
> Is it possible to let distcc produce even more verbose messages? The ones I
> get right now do not seem to be very informative. What does backoff period
> actually mean?

When distcc tries to distribute work to a particular host, and that fails,
distcc temporarily marks that host as "bad", and will not try distributing
any work to that host for the next 1 minute.  This is to avoid the
possibility of further overloading a host that is already overloaded.

Still any ideas what could be wrong?

We still don't have enough information.
Try running the build, then when it fails either wait one minute, or do the
rm commands that you did before,

   rm -rf /root/.distcc
   rm -rf /var/tmp/portage/.distcc

(but do NOT remove all the temporary build directories)
and then try the build again - hopefully the second time around, it won't
re-run the configuration steps.

Alternatively, if that still doesn't work, try removing those two .distcc
directories, and then running just the distcc command, e.g. (from your log

distcc i686-pc-linux-gnu-g++ -D_BSD_SOURCE -D_XOPEN_SOURCE=500 -D_BSD_SOURCE
-DMAKE_KDENETWORK_LIB -march=k8-sse3 -mtune=k8 -O2 -pipe
-fomit-frame-pointer -ftree-vectorize -Wnon-virtual-dtor -Wno-long-long
-ansi -Wundef -Wcast-align -Wchar-subscripts -Wall -W -Wpointer-arith
-Wformat-security -fno-exceptions -fno-check-new -fno-common
-Woverloaded-virtual -fvisibility=hidden -O2 -DNDEBUG -DQT_NO_DEBUG -fPIC
-I/usr/kde/4.2/include -I/usr/kde/4.2/include/KDE -I/usr/include/KDE
-I/usr/include/qt4/QtXmlPatterns -I/usr/include/qt4/QtWebKit
-I/usr/include/qt4/QtHelp -I/usr/include/qt4/QtAssistant
-I/usr/include/qt4/QtDBus -I/usr/include/qt4/QtTest
-I/usr/include/qt4/QtUiTools -I/usr/include/qt4/QtScript
-I/usr/include/qt4/QtSvg -I/usr/include/qt4/QtXml -I/usr/include/qt4/QtSql
-I/usr/include/qt4/QtOpenGL -I/usr/include/qt4/QtNetwork
-I/usr/include/qt4/QtDesigner -I/usr/include/qt4/Qt3Support
-I/usr/include/qt4/QtGui -I/usr/include/qt4/QtCore -I/usr/include/qt4/Qt
-I/usr/share/qt4/mkspecs/default -I/usr/include/qt4 -D_GNU_SOURCE
-D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -march=k8-sse3 -mtune=k8 -O2
-pipe -fomit-frame-pointer -ftree-vectorize -o
CMakeFiles/kdenetwork.dir/kdenetwork_automoc.o -c

Fergus Henderson <fergus at google.com>
-------------- next part --------------
HTML attachment scrubbed and removed

More information about the distcc mailing list