[distcc] Re: Host connection seems to fail on W32 system (Cygwin)

Andrew Kreps andrew.kreps at gmail.com
Wed Nov 15 21:14:07 GMT 2006

On 11/15/06, Martijn Reuvers <martijn at twotribes.com> wrote:
> Hi all,
> I investigated some more but no matter what I do, it just doesn't seem to
> recognize the hosts i specify with DISTCC_HOST. It *always* compiles
> locally. If I set DISTCC_HOSTS="localhost/1", it still compiles locally with
> 4 processes, instead of the maximum allowned 1. It is as if distcc just
> doesn't read the DISTCC_HOSTS settings. Any clue?

Although I run Cygwin, I've never tried to implement distcc in that
environment.  I do have it running on Gentoo, though.  Is there a
Cygwin equivilant of distcc-config?  If you run that with --get-hosts,
what do you see?  Also, if you enable debug logging in distcc, do you
see any messages such as 'unable to distribute to xxxhost'?  Do you
see any logs appear on the machine the compilation is supposed to be
happening on?  It sounds like we need to dig into the logs a bit.

More information about the distcc mailing list