[distcc] Re: Host connection seems to fail on W32 system (Cygwin)

Martijn Reuvers martijn at twotribes.com
Fri Dec 15 12:42:35 GMT 2006

Hi Andrew,

Thanks for your post and my apologies for the delay in responding.

> Although I run Cygwin, I've never tried to implement distcc in that
> environment.  I do have it running on Gentoo, though.  Is there a
> Cygwin equivilant of distcc-config?  If you run that with --get-hosts,
> what do you see?  Also, if you enable debug logging in distcc, do you
> see any messages such as 'unable to distribute to xxxhost'?  Do you
> see any logs appear on the machine the compilation is supposed to be
> happening on?  It sounds like we need to dig into the logs a bit.

I went through all the logs and couldn't find anything remotely similar to:
unable to distribute to xxxhost. As a matter of fact, the logs never mention
a single host I specified. Not even something like: reading config file,
found 3 hosts. No it simply always default to localhost :( It looks like if
the host settings are never read.

Furthermore I couldn't find an equivalent of distcc-config for W32 (Cygwin).
If someone does have that, please let me know.

Thanks for your help!



More information about the distcc mailing list