[distcc] Re: Host connection seems to fail on W32 system (Cygwin)

Martijn Reuvers martijn at twotribes.com
Wed Nov 15 11:04:20 GMT 2006

Hi all,

I investigated some more but no matter what I do, it just doesn't seem to
recognize the hosts i specify with DISTCC_HOST. It *always* compiles
locally. If I set DISTCC_HOSTS="localhost/1", it still compiles locally with
4 processes, instead of the maximum allowned 1. It is as if distcc just
doesn't read the DISTCC_HOSTS settings. Any clue?



Martijn Reuvers wrote:
> Hi all,
> Somehow my distcc only compiles at the localhost. I've tried numerous things
> like, setting the DISTCC_HOST environment variable. Setting up a host file
> in the DISTCC_DIR directory. Passing the hosts as an argument with make.
> Nothing works, I only get it to compile on the localhost, even if I set
> DISTCC_FALLBACK=0 and I remove the localhost from the host file etc, it
> still compiles locally, even though it shouldn't.
> My CC looks like this:
> CC := distcc.exe $(CW_BINDIR)/mwccarm.exe
> A rule in my makefile used for building a library looks like this:
> 	make -j12 -e --directory=../lib  \
> Which translated in my output window to:
> distcc.exe C:/Program\ Files/compiler/mwccarm.exe -lang c++ -c
> ./src/source.cpp -MD -o obj/ARM9-TS/Release/source.o
> as said, the compiling through distcc goes right, but somehow it doesn't
> recognize the other host.
> On the other host I ran distccd --deamon, with the correct allow settings. I
> checked firewalls. I can even telnet to the corresponding computer to port
> 3632, but somehow distcc won't do a thing with it.
> My distcc version is 2.18.3
> What do I do wrong?? Can you please mail an answer to my emailaddress and
> not only to the list?
> Thanks in advance!
> Cheers,
> Martijn Reuvers
> __ 
> distcc mailing list            http://distcc.samba.org/
> To unsubscribe or change options: 
> https://lists.samba.org/mailman/listinfo/distcc

More information about the distcc mailing list