[distcc] apt-0.5.5cnc4.1 + distcc-2.0.1 = error on build

Bob Tanner tanner at real-time.com
Mon Apr 7 04:28:15 GMT 2003

Trying to compile apt-0.5.5cnc4.1 using distcc and I get the following error:

Compiling contrib/fileutl.cc to 
/var/tmp/apt-0.5.5cnc4.1/obj/apt-pkg/fileutl.opic sed: can't read 
/var/tmp/apt-0.5.5cnc4.1/obj/apt-pkg/crc-16.d: No such file or directory
		                   The above varies, from run to run.

I figured this was something in the Makefiles, but:

$ find . -name "[Mm]akefile" | xargs grep sed

No sed in any of the [Mm]akefiles. 

Tried the masquarde stuff and still get the error. I "hid" the call to discc 
behind a shell script called gcc early in my path, still get the error.

Compiling make -j2 on a smp machine without distcc works fine.

Any recommendations?

apt, can be gotten here:  http://moin.conectiva.com.br/AptRpm
Bob Tanner <tanner at real-time.com>         | Phone : (952)943-8700
http://www.mn-linux.org, Minnesota, Linux | Fax   : (952)943-8500
http://www.linuxjustworks.com             | Linux Just Works!         
Key fingerprint = AB15 0BDF BCDE 4369 5B42  1973 7CF1 A709 2CC1 B288

More information about the distcc mailing list