WEP problem with mini-pci, RH7.3

Patrick Cole z at amused.net
Tue Sep 3 10:29:13 EST 2002

Sun, Aug 25, 2002 at 02:44:27PM -0500, Dan Pryma wrote:

> I am trying to get wireless networking going on my laptop (Gateway 450)
> that has a mini-pci orinoco card on RH7.3. Unencrypted wireless works
> just fine, but for some reason when I enter a secure key, it doesn't
> take. I have tried entering the key in wireless.opts as well as in
> config.opts, but for some reason when I run iwconfig eth1 it still lists
> encryption as off. Any ideas?

Are you sure the key you put in there is the right length? 

For the Silver type cards (not sure what your minipci is equivelant
to...) you get a 64bit (40bit) key - ie. 5 characters of text maximum.

For the Gold type cards you get 128bit (104bit) - ie. 13 characters
of text maximum.

If you go over the limit, the ioctl iwconfig does will simply fail
with most card drivers...

Patrick Cole <Patrick.Cole at anu.edu.au>
Programmer, the John Curtin School of Medical Research, ANU 
PGP 1024R/60D74C7D C8E0BC7969BE7899AA0FEB16F84BFE5A   

More information about the wireless mailing list