Orinoco Gold / Dell 7000 Driver Problem - Need Help

James L. Reese jim at hosemore.net
Fri Oct 12 05:30:31 EST 2001

Hello all.

I've got a Dell Inspiron 7000 that I'm trying to make work with an 
Orinoco Gold PCMCIA card.  I need help.

This is a redhat 7.1 system, but I'm running kernel 2.4.9 compiled from 
the kernel.org source tree.  It is patched with the Win4Lin kernel patch.

I've tried the hermes/orinoco_cs driver that came with the kernel source 
as well as the Lucent wavelan2_cs and cannot get the card to initialize.

I'd prefer to use the orinoco_cs driver, so I've removed all the stuff 
related to the wavelan2_cs and here's what I get when plugging the card:

cardmgr[583]: socket 1: Lucent Technologies Wavelan/IEEE
cardmgr[583]: executing: 'modprobe hermes'
cardmgr[583]: executing: 'modprobe orinoco_cs'
kernel: eth1: Error -110 reading firmware info. Wildly guessing 
kernel: hermes @ 0x100: CMD register busy in hermes_issue_command().
kernel: eth1: failed to read MAC address! kernel: orinoco_cs: 
register_netdev() failed
cardmgr[583]: get dev info on socket 1 failed: Resource temporarily 

If I run 'cardctl ident' it correctly identifies the card when it is 

I'm using the kernel pcmcia and I have not tried disabling that and 
loading pcmcia card services seperately from the kernel.

Any ideas?  I'm stumped.

More information about the wireless mailing list