[Samba] missing msdfs referrals from samba directory listing: wrong order in smbd_dirptr_get_entry()?

Michael Tokarev mjt at tls.msk.ru
Fri Jun 7 06:53:34 UTC 2024

07.06.2024 07:59, Michael Tokarev wrote:
> 07.06.2024 07:54, Jeremy Allison wrote:
>>> msdfs is broken in 4.19.  It worked fine in 4.18.
> This is not entirely true.

Nope. Things are more interesting than that.

I've a 4.19 installation where msdfs links works both in listing
and when specified directly. There are 2 other installations of 4.19
where msdfs links doesn't work neither in listing nor when used directly.
And there was another install of 4.19 where msdfs isn't shown in dir
listing but works when specified directly - I upgraded this one to
4.20 today which fixed the issue there.  When direct access to msdfs
link doesn't work, windows report "file does not exist" error.

I can't see what's the actual difference, trying to debug it further.
At least 2 of these installs are identically configured member servers
of the same domain - one which I upgraded to 4.20 and another where
msdfs links doesn't work neither in listing nor directly (yesterday
it was both 4.19 but on one of them, direct access to msdfs links
worked while on another, reported as non-existing file).


GPG Key transition (from rsa2048 to rsa4096) since 2024-04-24.
New key: rsa4096/61AD3D98ECDF2C8E  9D8B E14E 3F2A 9DD7 9199  28F1 61AD 3D98 ECDF 2C8E
Old key: rsa2048/457CE0A0804465C5  6EE1 95D1 886E 8FFB 810D  4324 457C E0A0 8044 65C5
Transition statement: http://www.corpit.ru/mjt/gpg-transition-2024.txt

More information about the samba mailing list