[Samba] Upgrade from 4.6.7 to 4.17.4 fails with database problem (Failure during re-pack, so transaction must be aborted)

Rowland Penny rpenny at samba.org
Wed May 17 14:11:48 UTC 2023

On 17/05/2023 13:50, Ricardo Esteves wrote:
> Hi,
> Strange, i don't know how that link went, but the msg i sent was with 
> the answers to your questions. Let me send them again:
> Have you tried with the OS Samba packages ?
> Just in case it is a compile problem ?
>      - Yes, i get the same error when i start samba from the OS packages.
> Can we confirm what version of Fedora your Samba domain is running on 
> and what Samba version ?
>      - Fedora 37 / Samba 4.6.7 (compiled from sources)

So you are running a very EOL version of Samba on a fairly recent 
version of Fedora, why ?

>   What version of Fedora you are trying to join to your existing domain ?
>      - I'm not trying to join any host. I'm upgrading samba on the 1st 
> domain controller from 4.6.7 to 4.17.4 or to 4.18.2

Ah we are getting to the crux of matter here, I would never recommend 
upgrading a self compiled version of Samba in this way. There have been 
instances of files being removed from the version of Samba that you are 
upgrading to, that still exist on disk.
I would recommend setting up a new computer (which may be a VM), 
installing Samba on that and join that to the existing domain, the old 
DC's can then be removed.

>   What is the exact command you are running in your attempt to join to 
> the domain ?
>       - I'm not trying to join any host.
>   What is the error you get when the join fails ?
>      - When i start samba on the DC after upgrading it, it doesn't start 
> and i see on the log.samba this msg: Samba failed to prime database, 
> error code 22[1]

That is probably because your method of upgrading Samba has probably 
wiped your database.


More information about the samba mailing list