[Samba] Synology shares not accessible...

Ingo Asche foren at asche-rz.de
Tue Jun 20 18:48:14 UTC 2023

There was a Travis Wenks here, who has/had the same problems.

I'm still hoping, he's reading the Samba mail list and tell me if he has 
still the same problems and we maybe can ally for this.

Maybe the maintainers who has answered to the bug report can give some 
advice, too.

The problem for me is that the developers from Synology think it can't 
be their fault. It's a little bit frustrating.


Rowland Penny via samba schrieb am 20.06.2023 um 20:17:
> On 20/06/2023 18:30, Ingo Asche via samba wrote:
>> Hi Rowland,
>> to be clear, I'm completely your opinion.
>> They had a running 4.15.9(-0619, their own build number), which was a 
>> Beta, and the released version (-0632) didn't worked. So for me it's 
>> obvious, too.
>> I can bring the released version to run with a library from their 
>> beta version: libidmap-samba4.so. The reason for this as they wrote:
>> "A key difference between SMB packets 0619 and 0632 is whether the ID 
>> map needs to verify the SID over the network before converting it to 
>> a UID/GID.Version 0619 retains the old Samba method of not doing 
>> network polling, but from version 0624 onwards network polling is 
>> done." (Translated from German)
>> Whatever they meant with "old Samba method"
> Perhaps someone else knows what that means, because I do not.
>>> Patch what, with what ?
>>> Do they not specify or provide a patch ?
>>> The bug report you provided a link to is still ongoing, it doesn't 
>>> seem to have come to a conclusion.
>> They seem to believe the attachments in the bug report are patches 
>> which you can install.
> That patch is now possibly out of date and may require rebasing on the 
> Samba code, there is also the fact that, from your testing on a later 
> Samba version, you do not get the problem on other machines, perhaps 
> it has been fixed in another way ? What if you fix it so that synology 
> machines work and this causes problems for your other machines ?
>>> So, it is only the synology machines that have the problem, other 
>>> machines against your DC's do not have the problem. To me, that 
>>> sounds like the problem lies on the synology machines, or am I 
>>> missing something (which wouldn't be the first time).
>> I agree. I have three of them. The oldest one with Samba 4.4.18 makes 
>> no problems. Their interpretation of Samba 4.15.x makes the problem, 
>> except for the beta.
>>> Well, it sounds that way to me, but there in lies another possible 
>>> problem. If you do have to patch the synology machines, this will 
>>> entail patching and building synology's version of Samba, have they 
>>> supplied you with the source code ?
>> I wanted only to know based on the bug report, is it something, which 
>> has to fixed on the DCs or the device which has shows the mentioned bug.
>>> I personally wouldn't want to patch my DC's to get a synology 
>>> product to work correctly, if doing so could break the rest of my 
>>> domain.
>>> I could be extremely wrong here, but it makes more sense to me, to 
>>> fix the 'broken' thing, rather than 'unbroken' things.
>> Again, agreed. I think, you're right here, too...
>>> I would go back to synology and get them to clarify just what they 
>>> would like you to do and how you should do it.
>> That I will, I just hoped for some knowledge that will strengthen my 
>> arguments.
>>> Rowland
>> As always, thanks for your answer...
> I suppose the question has to be, does anyone else have this problem 
> and if they do, are they using synology ?
> Rowland

More information about the samba mailing list