[Samba] PAM Offline Authentication in Ubuntu 22.04

Rowland Penny rpenny at samba.org
Thu Jun 15 12:54:27 UTC 2023

On 14/06/2023 12:10, Rowland Penny via samba wrote:
> On 14/06/2023 11:48, Michael Tokarev via samba wrote:
>> This shouldn't be a problem by its own.  On a laptop without its own 
>> local domain
>> name it doesn't matter much which domain search to use, and "." is 
>> about right
>> anyway.
> I totally agree, it shouldn't matter, but this (in my case) isn't a laptop.
> I know that it may have something to do with my router and so I will 
> have to set up another dhcp server that I can totally control, but I 
> doubt if this will help because the router is sending a domain name, 
> just not the correct one.

OK, dhcp server on router turned off, new dhcp server set up 

It all now works.

I ran Louis's script and got much the same results as Marco. Fixed the 
dhcp server and ran the script again and got just one error and that was 
about '' in /etc/resolv.conf, so I ignored it.

Set up Samba correctly, joined the domain and logged in, logged out, 
disconnected network, logged in again, ran 'wbinfo -P', which failed, 
reconnected network and ran 'wbinfo -P' and it worked.

So, I suggest Marco looks very closely at his DNS, I am sure he has a 
problem there somewhere.


More information about the samba mailing list