[Samba] Samba 4.16 and 4.17 ubuntu focal and jammy packages

Michael Tokarev mjt at tls.msk.ru
Tue Oct 25 17:50:09 UTC 2022

25.10.2022 20:41, ralph strebbing wrote:

> So we're upgrading (test environment) from 4.15 on Van-belle's repo on
> Ubuntu 20.04 to 4.17 on your repo, but I'm consistently getting the
> following error, no matter what I've tried, which so far has been
> removing all of the samba packages listed on
> https://wiki.samba.org/index.php/Distribution-specific_Package_Installation#Debian.2FUbuntu
> Then running apt autoremove
> Then reinstalling the programs on the above link. However what I run into is:
> Unpacking samba (2:4.17.2+dfsg-1focal) ...
> dpkg: error processing archive
> /tmp/apt-dpkg-install-zJKlpj/11-samba_2%3a4.17.2+dfsg-1focal_amd64.deb
> (--unpack):
>   trying to overwrite '/etc/pam.d/samba', which is also in package
> samba-common 2:4.17.2+dfsg-1focal

There was a bug in here, see http://bugs.debian.org/1022776 .

I gave all my attention to the ubuntu packaging, and a trivial but bad bug
slipped into the main thing.

4.17.2+dfsg-2~focal is being built right now, I will upload it in ~20 minutes.

There will be no rush next time, once initial repository creation dust


More information about the samba mailing list