[Samba] Samba 4.16 and 4.17 ubuntu focal and jammy packages

ralph strebbing blackbirdralph at gmail.com
Tue Oct 25 17:41:36 UTC 2022

On Tue, Oct 25, 2022 at 9:23 AM Michael Tokarev <mjt at tls.msk.ru> wrote:
> Oh. I forgot to mention. All Debian keys are available at keyring.debian.org,
> so you can grab the key like this:
>   gpg --keyserver keyring.debian.org --recv-key 6EE195D1886E8FFB810D4324457CE0A0804465C5
> and you can export it like this:
>   gpg --export 6EE195D1886E8FFB810D4324457CE0A0804465C5 > mjt.key
> to be used with apt - either put it to /etc/apt/trusted.gpg.d/, or use
> this key in sources.list entry like this (for example):
>   deb [signed-by=/etc/apt/mjt.key] http://www.corpit.ru/mjt/packages/samba ubuntu-22.04-jammy/samba-4.17/
Thanks for this!
So we're upgrading (test environment) from 4.15 on Van-belle's repo on
Ubuntu 20.04 to 4.17 on your repo, but I'm consistently getting the
following error, no matter what I've tried, which so far has been
removing all of the samba packages listed on
Then running apt autoremove
Then reinstalling the programs on the above link. However what I run into is:
Unpacking samba (2:4.17.2+dfsg-1focal) ...
dpkg: error processing archive
 trying to overwrite '/etc/pam.d/samba', which is also in package
samba-common 2:4.17.2+dfsg-1focal
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)

Any ideas here? Googling led me to the potential solution of using
--force-overwrite in the apt install command, but I was also warned
off about that. Just want to make sure I'm not missing something
simple here.


More information about the samba mailing list