[Samba] function level 2012_R2

Никитин Илья lifefrag at lifefrag.ru
Thu Jul 21 12:42:22 UTC 2022

being a beginner, I encountered such a question - it is impossible to raise the domain level (domain provision --function-level=2012_R2 and domain level raise --domain-level=2012_R2), on version 4.13.13.
I will say right away that only the functionality of a domain controller is needed.
OS: Debian 11.
What was done:
1) by default, the maximum domain level is limited to 2008_R2 and, accordingly, when you try to raise the level, a message appears with an error in the option and a list of available maximum domain level 2008_R2 (which is logical);
2) tried to build a more recent package (in my situation this is 4.13.14, do not ask why) in it by default, the situation is one to one with point number 1;
3) when building the package, once again, I tried to find options to unlock access (options) to the function of creating\raising the level of the domain to 2012_R2 and did not find it. It is likely that i could overlook;
4) check scheme version = 69;
what result am I trying to achieve:
1) deployed AD DC 2012_R2 (domain level and forest)
2) or find a list of flags required to compile a .deb package with this function (if these flags exist)
Thanks in advance

More information about the samba mailing list