[Samba] function level 2012_R2

Rowland Penny rpenny at samba.org
Thu Jul 21 13:10:39 UTC 2022

On Thu, 2022-07-21 at 15:42 +0300, Никитин Илья via samba wrote:
> Hello.
> being a beginner, I encountered such a question - it is impossible to
> raise the domain level (domain provision --function-level=2012_R2 and
> domain level raise --domain-level=2012_R2), on version 4.13.13.
> I will say right away that only the functionality of a domain
> controller is needed.
> OS: Debian 11.
> What was done:
> 1) by default, the maximum domain level is limited to 2008_R2 and,
> accordingly, when you try to raise the level, a message appears with
> an error in the option and a list of available maximum domain level
> 2008_R2 (which is logical);
> 2) tried to build a more recent package (in my situation this is
> 4.13.14, do not ask why) in it by default, the situation is one to
> one with point number 1;
> 3) when building the package, once again, I tried to find options to
> unlock access (options) to the function of creating\raising the level
> of the domain to 2012_R2 and did not find it. It is likely that i
> could overlook;
> 4) check scheme version = 69;
> what result am I trying to achieve:
> 1) deployed AD DC 2012_R2 (domain level and forest)
> 2) or find a list of flags required to compile a .deb package with
> this function (if these flags exist)
> Thanks in advance

Sorry but it isn't going to work, not even if you upgrade to the latest
Samba version. Samba, whilst it now uses the 2012R2 schema, cannot be
raised to the 2012R2 functional level, it is getting close, but isn't
quite there yet.


More information about the samba mailing list