[Samba] PSO and group names with spaces

Victor Rodriguez vrodriguez at soltecsis.com
Wed Feb 23 08:28:39 UTC 2022

Sorry to insist about this, but I'm worried that I might be just doing 
something wrong when using the command.

Does "samba-tool domain passwordsettings pso apply" support group names 
with spaces?

Has anyone tried it?

Thanks in advace.

On 2/16/22 13:17, Victor Rodriguez via samba wrote:
> Hello,
> Trying to set up PSO on a domain that has a lot of group names with 
> spaces. When I try samba-tool group show "Group Name" I get the group 
> information, members, etc.
> If I try samba-tool domain passwordsettings pso apply "pso_test" 
> "Group Name" I get:
> "ERROR: The specified user or group 'Group Name' was not found".
> If I try with a non-spaced group name it does work as expected:
> samba-tool domain passwordsettings pso apply "pso_test" test1
> PSO 'pso_test' applied to 'test1'
> Do I have to escape the group name somehow? Tried a few combinations 
> with \ and + but none worked.
> BTW, samba-tool is v4.13.14-Ubuntu.
> Thanks!

More information about the samba mailing list