[Samba] Samba support for Sonos S1 versions 4.15 and above

Barry de Graaff sonos at barrydegraaff.nl
Fri Dec 9 18:31:10 UTC 2022

Hello everyone,

Since Samba version 4.15 I have not been able to connect Sonos S1 to 
Samba. I have tried this on Ubuntu 22.04. There are some permission 
changes on Ubuntu. So I also tried Debian unstable (sid) which has Samba 
version 4.17, but there I have the same result, Sonos says permission 
denied. It works fine on Samba version 4.13 in Debian 11 and Ubuntu 

As a work-around I modified a node-based SMB server details at 
https://barrydegraaff.nl/sonossmb/ that works well and gives me some 
idea of how Sonos S1 has implemented SMB protocol. So at least I have my 
music for Christmas.

With the smb.conf as below I am able to browse the defined share with 
SMB1 and ntlmv1 authentication using Samba version 4.17, but then Sonos 
does not work. If I do the same on 4.13 it works. When I use smbclient 
on my self baked node-smb server it works as well, the spnego=no and 
ntlmv2=no on the client are required to make smbclient work. Sonos does 
not seem to use lanman authentication as that is not implemented in the 
node-smb server.

I have seen this wiki 
but that does not help me.

Other then Wireshark and dumping the Sonos firmware can you give me any 
tips on how to resolve this issue?

Thanks and merry x-mas.


smbclient \\\\\\PUBLIC -U guest%

    #Required for Sonos S1
    server min protocol = NT1
    ntlm auth = ntlmv1-permitted
    client min protocol = NT1
    client use spnego = no
    client ntlmv2 auth = no

    workgroup = WORKGROUP
    server string = Samba Server Version %v
    security = USER
    map to guest = Bad User
    log file = /var/log/samba/log.%m
    max log size = 50
    idmap config * : backend = tdb
    cups options = raw
    ntlm auth = true

# User defined share
    path = /public
    read only = Yes
    guest ok = Yes
    browseable = Yes
    public = Yes

More information about the samba mailing list