[Samba] Samba support for Sonos S1 versions 4.15 and above

Jeremy Allison jra at samba.org
Fri Dec 9 20:39:43 UTC 2022

On Fri, Dec 09, 2022 at 07:31:10PM +0100, Barry de Graaff via samba wrote:
>Hello everyone,
>Since Samba version 4.15 I have not been able to connect Sonos S1 to 
>Samba. I have tried this on Ubuntu 22.04. There are some permission 
>changes on Ubuntu. So I also tried Debian unstable (sid) which has 
>Samba version 4.17, but there I have the same result, Sonos says 
>permission denied. It works fine on Samba version 4.13 in Debian 11 
>and Ubuntu 20.04.
>As a work-around I modified a node-based SMB server details at 
>https://barrydegraaff.nl/sonossmb/ that works well and gives me some 
>idea of how Sonos S1 has implemented SMB protocol. So at least I have 
>my music for Christmas.
>With the smb.conf as below I am able to browse the defined share with 
>SMB1 and ntlmv1 authentication using Samba version 4.17, but then 
>Sonos does not work. If I do the same on 4.13 it works. When I use 
>smbclient on my self baked node-smb server it works as well, the 
>spnego=no and ntlmv2=no on the client are required to make smbclient 
>work. Sonos does not seem to use lanman authentication as that is not 
>implemented in the node-smb server.
>I have seen this wiki https://wiki.samba.org/index.php/Samba_Features_added/changed#NTLMv1_authentication_disabled_by_default 
>but that does not help me.
>Other then Wireshark and dumping the Sonos firmware can you give me 
>any tips on how to resolve this issue?

I use SONOS against my Ubuntu-based fileserver.

The only two [global] settings I need are:

         ntlm auth = yes
         server min protocol = NT1

More information about the samba mailing list