[Samba] samba 4.9.7 - DC online backup error - "uncaught exception - 'TarFile' object has no attribute '__exit__'"

Carlos Gardel carlosito2021 at outlook.com
Wed Mar 24 12:33:50 UTC 2021

Hello Andrew,

Thank you for your input. I really appreciate getting suggestions and advice from such a prominent Samba veteran!

According to your thoughts my plan will be to start to join a new DC (DC3) to the domain and then try to do an online backup on the new DC. Hopefully this will work better.

If all work out well I plan to transfer the FSMO rules to DC3 (from the current holder DC1). Is there certain steps I need to take before or after the transfer of the FSMO rules? Do I need to change DNS entries etc? I suppose I need to change the rsync based Sysvol replication (which I have set up according to https://wiki.samba.org/index.php/Rsync_based_SysVol_replication_workaround) to replicate from DC3 to DC1 (instead from DC1 to other DC:s as is now the case).

Thanks again and best regards,


From: Andrew Bartlett <abartlet at samba.org>
Sent: Friday, March 19, 2021 7:12 PM
To: Carlos Gardel <carlosito2021 at outlook.com>; samba at lists.samba.org <samba at lists.samba.org>
Subject: Re: [Samba] samba 4.9.7 - DC online backup error - "uncaught exception - 'TarFile' object has no attribute '__exit__'"

On Thu, 2021-03-18 at 19:27 +0000, Carlos Gardel via samba wrote:
> Hi,
> I've been running two DC:s (DC1 and DC2) in a pure samba AD domain
> since 2015 on Centos 6. Starting with version 4.1.14 I have upgraded
> my way to version 4.9.7. It seems I have now reached the limit for
> possible upgrades of these DC:s since it is no longer possible to
> upgrade to 4.10 on Centos 6.
> I'm now preparing to deploy a DC3 on a Centos 8 vm with samba 4.14.0.
> Before joining it to the domain I have tried to make an online backup
> of the AD on the two existing DC:s following the guide at
> https://wiki.samba.org/index.php/Back_up_and_Restoring_a_Samba_AD_DC.
> When I run the command (as root) "samba-tool domain backup online --
> targetdir=/root/samba-backup/ --server=DC2 -UAdministrator" I get the
> following error:

> I would be very grateful for all the help I can get since it would
> feel fantastic to be able to perform a backup before I start to join
> new DC:s and make changes to the existing setup.

The backup is taken over the network, so just start he backup on a new
modern Samba version, rather than with the old one.

Python 2.6 was poorly tested with Samba - every release we would have a
bug filed about some issue or other - which is one of the reasons we
raised the minimum version recently to 3.5 and 3.6 - it was becoming
foolish to pretend to support versions that we didn't run CI on.

Andrew Bartlett

> Best regards,
> Carlos
Andrew Bartlett (he/him)       https://samba.org/~abartlet/
Samba Team Member (since 2001) https://samba.org
Samba Team Lead, Catalyst IT   https://catalyst.net.nz/services/samba

Samba Development and Support, Catalyst IT - Expert Open Source

More information about the samba mailing list