[Samba] "not enough space" on share with mountpoints inside

L.P.H. van Belle belle at bazuin.nl
Thu Mar 11 15:03:52 UTC 2021

Sound familiar.. 

samba version? 
smb.conf ? 

These things really help us to help you..

> -----Oorspronkelijk bericht-----
> Van: samba [mailto:samba-bounces at lists.samba.org] Namens Alpe via samba
> Verzonden: donderdag 11 maart 2021 15:00
> Aan: samba at lists.samba.org
> Onderwerp: [Samba] "not enough space" on share with mountpoints inside
> I have a share named "media" that points to the folder that contains the
> mountpoints of my external drives.eg:
> \\server\media\mountpoint1\\server\media\mountpoint2
> If i try to write something to any mountpoint I get a "not enough space"
> error.However, if I mount the mountpoint directly to a Windows letter (eg:
> Z:) it works.The same problem also occurs on linux clients.
> I used the "dfree command" command option to log what folder samba is
> checking for free space.When I try to write to
> "\\server\media\mountpoint1" samba checks for ".", but if I mount this
> folder in Z: and try writing to it, samba checks "mountpoint1" as
> expected.
> It stopped working yesterday. It always worked before.
> Yesterday I though it would be a good idea to update all pip3 packages.
> Maybe this is what caused the issue.
> I already tried:
> apt install samba --reinstall
> build from source
> But the issue persists.Anyone have any idea what could be the problem? Or
> what library/module/program is responsible for deciding which folder to
> check. I may have broken it, so I could try reinstalling it too.
> Thanks.
> --
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/mailman/options/samba

More information about the samba mailing list