[Samba] "not enough space" on share with mountpoints inside

Alpe douglas.alpe-samba at yahoo.com
Thu Mar 11 14:00:23 UTC 2021

I have a share named "media" that points to the folder that contains the mountpoints of my external drives.eg:

If i try to write something to any mountpoint I get a "not enough space" error.However, if I mount the mountpoint directly to a Windows letter (eg: Z:) it works.The same problem also occurs on linux clients.
I used the "dfree command" command option to log what folder samba is checking for free space.When I try to write to "\\server\media\mountpoint1" samba checks for ".", but if I mount this folder in Z: and try writing to it, samba checks "mountpoint1" as expected.

It stopped working yesterday. It always worked before.
Yesterday I though it would be a good idea to update all pip3 packages. Maybe this is what caused the issue.

I already tried:
apt install samba --reinstall
build from source

But the issue persists.Anyone have any idea what could be the problem? Or what library/module/program is responsible for deciding which folder to check. I may have broken it, so I could try reinstalling it too.


More information about the samba mailing list