[Samba] ../../source4/libcli/dgram/browse.c:106(dgram_mailslot_browse_parse) followed by NT_STATUS_BUFFER_TOO_SMALL

Rowland Penny rpenny at samba.org
Tue Aug 10 17:13:57 UTC 2021

On Tue, 2021-08-10 at 18:15 +0200, Bas W. Auer via samba wrote:
> Hi all,
> I have a question about an error I get after upgrading SAMBA 4.11.6
> to 
> 4.12.0 and further.
> First a little history up front.
> I had a Centos 7 SAMBA 4.11.6 server running, but because of the EOL
> of 
> Centos 7 and the strange shift of RedHat with Centos I couldn't
> upgrade 
> SAMBA and couldn't upgrade Centos, so I decided to switch to my 
> favourite OS, Ubuntu.
> So I created an Ubuntu 20.04 server, and installed Samba 4.11.6 with
> the 
> same configure string. (Followed the samba wiki by the letter)
> Then I joined this new machine to the Centos 7 SAMBA AD again
> following 
> the wiki page. Everything turned out perfectly. Brought both machines
> in 
> sync, again following the samba wiki. Everything worked as supposed.
> Then I demoted the old Centos 7 SAMBA AD and removed all pointers to 
> that machine on the new Ubuntu 20.04 SAMBA AD. (Again following the 
> samba wiki)
> The demotion worked, the old machine I shutdown and I started
> testing. 
> Everything works like a charm. No errors, I can create users, dns 
> entries etc.
> After a few days of working with this new setup, still no errors, I 
> decided that I could and should upgrade SAMBA to the newest version.
> Not 
> with a bang, but in steps. Going from 4.11.6 to 4.12.0 etc to
> finally 
> end with the latest version in a few weeks.
> The upgrade went perfect (I think) and everything started as
> supposed 
> to. Again I could create a user, add DNS entries, remove them etc.
> No 
> errors or what so ever. Until 10 minutes after (re)starting SAMBA
> 4.12.0.
> I get the following errors after approx. 10 minutes after staring and
> it 
> repeats every +/- 10 minutes.
> ../../source4/libcli/dgram/browse.c:106(dgram_mailslot_browse_parse)
> Failed to parse browse packet of length 32:
> I looked every where for an answer, but I couldn't find any answer
> that 
> helped.
> I probably missed something in the upgrade, but I don't know where
> to 
> look, as I think I looked everywhere.
> I hope someone in this community can help me.

Last time I remember seeing things like this on a DC, it was using the
experimental MIT kerberos. Where are you getting Samba from ?


More information about the samba mailing list