[Samba] Long re-index on upgrade from 4.10.x to 4.11.x

Rowland penny rpenny at samba.org
Sat Mar 7 12:06:49 UTC 2020

On 07/03/2020 00:52, Andrew Bartlett wrote:
> On Thu, 2020-03-05 at 15:09 +0000, Rowland penny via samba wrote:
>> On 05/03/2020 14:58, Stefan G. Weichinger via samba wrote:
>>> Am 05.03.20 um 10:48 schrieb Stefan G. Weichinger via samba:
>>>> Am 05.03.20 um 10:40 schrieb Rowland penny via samba:
>>>>> On 05/03/2020 08:34, Stefan G. Weichinger via samba wrote:
>>>>>> downgrade or fix ;-)  ?
>>>>> This hit me yesterday, restart the DC, check with 'ps ax' and I think
>>>>> you will find that only 'Samba' has started. If so walk away, have a
>>>>> three course meal and go to the cinema, hopefully when you get back, it
>>>>> will have finished reindexing your database.
>>>> kind of, yes. short: works now
>>>> longer: reinstalled samba, found samba-ad-dc.service masked (why? who?)
>>>> ... unmasked it and decided to restart. Works now.
>>>> thanks for now. I will wait with the second DC, one or two days.
>>> I have to add that the customer had issues while DC1 was reindexing or
>>> whatever ...
>> It took nearly 5 hours in my case and during that time, only the samba
>> binary was running, no smbd or winbind.
> The startup re-index is not meant to take that long, this is quite a
> concern.  The decision to force a re-index was taken on the basis of
> testing that it was pretty fast, triggered at first startup and only a
> few seconds in duration.
> It certainly wasn't meant to be a 5-hour offline operation, even for
> massive databases.
I never thought it was and by no means can you describe my database as 
massive :-(

Something went wrong during the upgrade, it could have something to do 
with the fact that I upgraded the distro and Samba at the same time. I 
tried to just upgrade the distro without out upgrading Samba, but this 
failed for dependencies, so I upgraded Samba at the same time. I have 
done this in the past without any problems.

Once the upgrade finished, seemingly without any errors, Samba was 
running, but only the samba binary. I looked in the logs, but there were 
no errors shown, so I raised the log level to 4 and restarted Samba, I 
now had the 'reindex' lines in the log, so I did at least know what was 
going on. It took 5 hours before smbd and winbind were started.

However, this wasn't the end of it, I decided to upgrade my other DC, so 
attempted to transfer the FSMO roles from this to my supposedly upgraded 
DC, they wouldn't transfer, something to do with the 'rid' FSMO. Tried 
to seize them to the supposedly upgraded DC, this failed for much the 
same reason.

At this point I decided to cut my losses, demoted the DC, cleaned up, 
renamed it and re-joined it the domain, this time everything worked as 


More information about the samba mailing list