[Samba] delayed write files errors

Rowland penny rpenny at samba.org
Sun Jan 5 13:27:25 UTC 2020

On 05/01/2020 11:36, Ni Co wrote:
> Hello Rowloand,
> ok, I just keep "default" for the mounting.
> I changed the path of my share :
> [homes]
> comment = User Home Folder
> path = /home/%U
> read only = no
> follow symlinks = yes
> wide links = yes
> browseable = no
> hide files = /desktop.ini/$RECYCLE.BIN/
You were using a share called '[users]' where a 'path' parameter is 
required, but you have now changed it to '[homes]'. This is a special 
share and does not allow the use of the 'path' parameter.
> I need Wide Links because in the share there are symbolics links to
> outside the share.
OK, but just ensure they cannot link to somewhere they shouldn't (such 
as '/')
> Anyway, I still get the same error with all this files :
>       mrxsmb :
> \.system\Thunderbird\profile.default-release\calendar-data\cache.sqlite-shm
> \.system\Thunderbird\profile.default-release\cookies.sqlite-shm
> \.system\Thunderbird\profile.default-release\places.sqlite-shm
> \.system\Thunderbird\profile.default-release\favicons.sqlite-shm
> \.system\Thunderbird\profile.default-release\webappsstore.sqlite-shm
By the backslashes, this appears to be coming from windows, so is there 
an event ID ?
> There is new errors in the samba log, like kerberos errors. I don't know
> if this errors are normals.

If there is nothing in the Samba log, then it either isn't a Samba 
problem, or it isn't appearing because the log level in smb.conf is too low.

> Also, I can see the file favicons.sqlite-shm in the samba log (@
> [2020/01/04 23:59:55.709000,  2]) with som errors.
What is the full log fragment ? The lines around the error.


More information about the samba mailing list