[Samba] Ldapsearch against Samba AD returns records outside the search base

Rowland penny rpenny at samba.org
Sun Feb 2 16:51:58 UTC 2020

On 02/02/2020 14:39, Christian Naumer via samba wrote:
> Hello all,
> I just tried this on our setup and it ist the same there. I get results
> from other OUs. Using sub instead of one I get the "right" results.
Problem is, I have tried the OP's search command against Samba 4.7.12, 
4.10.6 and 4.11.6

Created two OU's: OU=testou1 and OU=testou2

Created a user 'OUser1' in OU=testou1

I did this on all three versions of Samba and then ran the OP's 
ldapsearch command (modified for the dns domain) and depending on which 
OU I searched in (using -s one) I either got no result or the expected 
result, I even tried a non existing user and got nothing.

Or to put it another way, I cannot get the same result as the OP.

Time for a few questions:

What OS is the user using ?

Is the OP using distro packages, packages from somewhere else, or a self 
compiled Samba ?

If self compiled, how was it compiled ?

What is in smb.conf ?


More information about the samba mailing list