[Samba] Ubuntu 18.04 classicupgrade help

Carl Hunter cdhunter2 at yahoo.com
Thu Aug 6 16:00:50 UTC 2020

 On Wednesday, August 5, 2020, 03:06:57 p.m. EDT, Rowland penny via samba <samba at lists.samba.org> wrote:
 On 05/08/2020 19:58, Carl Hunter via samba wrote:
>  On Tuesday, August 4, 2020, 08:39:59 a.m. EDT, Carl Hunter via samba <samba at lists.samba.org> wrote:
>    On Tuesday, August 4, 2020, 06:43:52 a.m. EDT, Rowland penny via samba <samba at lists.samba.org> wrote:
>  On 04/08/2020 00:33, Carl Hunter wrote:
>> Next question.  I've got a script that's supposed to run at a user
>> login.  It works for the samba admin account.  I was able to change
>> the permissions in Windows to get a user account to work.  I just
>> tried a second user which I think is part of a different group than
>> the first user and the logon script doesn't seem to run.  Is there a
>> way in Windows (Windows 7 at the moment) to view all Samba AD DC users
>> and groups?  All shared drives are controlled like this right?  No
>> more chmod/chown?
> Where is the script located ? Netlogon ?
> What is it supposed to do ?
> AD (Windows or Samba) uses SIDs, so a Windows user should see all users
> and groups, but only on a Windows computer.
> It's a bit different on a Unix domain member, Samba makes domain users
> and groups into Unix ones, but not all of them.
> I hope you can see from that it depends on where the script is run and
> how, if it will work.
> A bit more info will help ;-)
> Rowland
> Yes, the script is in Netlogon.  It maps a bunch of shares to drive letters and remaps local user folders to folders on the server.  Even though the script doesn't seem to run for all users I can still get to the shares on the network.
> How would I go about creating or managing users with this Samba setup under Windows.  Is that possible?
> Thanks
> Carl
> Any ideas as to why some of my users don't seem to run the script in the Netlogon share?  Is there a way in Windows to check and see if an attempt was make to run the script?  Or on Linux?
> Thanks
> Carl

Not sure, Louis is the Windows expert here, but I think you would be 
better off using GPO's to do this instead of scripts, but only for your 
Windows clients, but again, Louis knows more about these than I do.

Turns out I don't think the script is running for any user.  If I manually run the script all the drive mappings are just stored locally so it looks like it runs on the next logins.  I think I'll try to figure out the GPO method which I think it one of the reasons to upgrade my NT4 domain to an active directory one.  
The main purpose for converting the domain was to be able to use Windows 10 machines.  I tried installing Windows 10 (1909) and join the domain but it's failing with the following error.  
The specified domain either does not exist or could not be contacted
I've got a Windows 7 machine that was already connected to the NT4 domain and seems to be connected to the new AD domain.  I can disconnect from the domain and reconnect with this machine and it works.  Any ideas about Windows 10?  

More information about the samba mailing list