[Samba] Cannot Find Windows Shared Printer

gw1500 i_was_yah00ed at yahoo.com
Mon Oct 14 15:55:03 UTC 2019

I am running CentOS 7 with Samba version 4.9.1. I have a Windows shared
printer that I cannot set up but I am not sure if this is a CentOS issue
or a Samba issue. When I run the printer setup GUI, it is not able to
find any shared printer. If I run smbclient I get this error:

smbclient -L dap001 -N
Unable to initialize messaging context
Anonymous login successful

?????????????? Sharename???????????? Type?????????? Comment
?????????????? ---------???????????? ----?????????? -------
smb1cli_req_writev_submit: called for dialect[SMB2_10] server[dap001]
Error returning browse list: NT_STATUS_REVISION_MISMATCH
Reconnecting with SMB1 for workgroup listing.
Anonymous login successful

?????????????? Server???????????????????????????? Comment
?????????????? ---------?????????????????????? -------

?????????????? Workgroup?????????????????????? Master
?????????????? ---------?????????????????????? -------

I understand the "Unable to initialize ..." error can be ignored but I
don't know what to do about the "NT_STATUS..." error. If it matters the
printer share name includes spaces. Please advise. TIA.

This email has been checked for viruses by Avast antivirus software.

More information about the samba mailing list