[Samba] Failed when join to an existing Active Directory Domain

Rowland penny rpenny at samba.org
Sat Oct 12 14:49:11 UTC 2019

On 12/10/2019 15:22, Igor Sousa wrote:
> Hi Rowland,
> My domain is a Samba Domain originally. I don't have any Windows DC 
> and I've never had a Windows DC in this domain, only Windows members. 
> My master DC is too old samba version and I've put a new DC with samba 
> 4.10.2 and I've tried to update a secondary DC that had had offline. 
> Then I have demonted it and compile a Samba 4.10.2 and I've tried to 
> join it with the same name and IP address as I've said before.
> Igor Sousa

The reason I asked about Windows is because your join fails here:

INFO 2019-10-11 17:49:04,753 pid:29652 
/usr/local/samba/lib64/python3.6/site-packages/samba/join.py #1160: 
Adding DNS A record GENOS.smb for IPv4 IP:

We have had a few reports like this recently and they failed on creation 
of the computers dns records because they started out as Windows 
2000/2003 domains and the dns records were very different.

What OS are you running ?

What was the Samba version that you are trying to replace, or to put it 
another way, what Samba version was it when the domain was provisioned ?

How have you compiled Samba, what was your configure line ?


More information about the samba mailing list