[Samba] Failing to join existing AD as DC

Rowland penny rpenny at samba.org
Mon Aug 26 09:58:29 UTC 2019

On 26/08/2019 10:37, Alexander Harm via samba wrote:
> OK, DNS is solved, I had to install dnsutils package on Debian for the DNS updates to work properly.
> But the non-existence of the Samba DCs in AD Users and Computers persists.
Try checking if the DCs exist in AD and if they are in the correct 
place, try this on one of the Samba DCs:

ldbsearch -H /var/lib/samba/private/sam.ldb -b 'OU=Domain 
Controllers,DC=samdom,DC=example,DC=com' -s sub 
'(&(objectClass=computer)(sAMAccountName=*))' sAMAccountName

Change it to match your domain etc.

It should display your DCs

Run the command on the other DC, you should get the same result.

You could also run this command:

ldbsearch -H /var/lib/samba/private/sam.ldb -b 
'CN=Computers,DC=samdom,DC=example,DC=com' -s sub 
'(&(objectClass=computer)(sAMAccountName=*))' sAMAccountName

It shouldn't display your DCs, but it should show any computers you have.


More information about the samba mailing list