[Samba] Failing to join existing AD as DC

Alexander Harm contact at aharm.de
Mon Aug 26 11:13:37 UTC 2019

When run on both Samba DCs the result is as expected. Just the Windows DC not showing the two DCs (different site if that is relevant) and the one client (same site as SambaDCs).

On 26. August 2019 at 11:59:18, Rowland penny via samba (samba at lists.samba.org) wrote:

On 26/08/2019 10:37, Alexander Harm via samba wrote:  
> OK, DNS is solved, I had to install dnsutils package on Debian for the DNS updates to work properly.  
> But the non-existence of the Samba DCs in AD Users and Computers persists.  
Try checking if the DCs exist in AD and if they are in the correct  
place, try this on one of the Samba DCs:  

ldbsearch -H /var/lib/samba/private/sam.ldb -b 'OU=Domain  
Controllers,DC=samdom,DC=example,DC=com' -s sub  
'(&(objectClass=computer)(sAMAccountName=*))' sAMAccountName  

Change it to match your domain etc.  

It should display your DCs  

Run the command on the other DC, you should get the same result.  

You could also run this command:  

ldbsearch -H /var/lib/samba/private/sam.ldb -b  
'CN=Computers,DC=samdom,DC=example,DC=com' -s sub  
'(&(objectClass=computer)(sAMAccountName=*))' sAMAccountName  

It shouldn't display your DCs, but it should show any computers you have.  


To unsubscribe from this list go to the following URL and read the  
instructions: https://lists.samba.org/mailman/options/samba  

More information about the samba mailing list