[Samba] Failing to join existing AD as DC

Alexander Harm contact at aharm.de
Mon Aug 26 09:37:27 UTC 2019

OK, DNS is solved, I had to install dnsutils package on Debian for the DNS updates to work properly.

But the non-existence of the Samba DCs in AD Users and Computers persists.

On 26. August 2019 at 11:27:04, Alexander Harm (contact at aharm.de) wrote:

OK, did everything as suggested, re-installed and joined the Samba instances to AD. Worked flawlessly so far.

However, there are two things I noticed which bother me a bit. On the Windows DC:

DNS Manager: the two Samba DCs are not listed as nameservers for the domain

AD Users and Computers: the two Samba DCs do neither appear in Domain Controllers nor under Computers

They both appear in AD Sites & Services correctly and as mentioned above, everything seems to work just fine.

Question: should I simply add them manually as nameservers (makes sense to me) and as domain controllers (probably makes no difference)?

On 16. August 2019 at 16:14:02, Rowland penny via samba (samba at lists.samba.org) wrote:

On 16/08/2019 15:02, L.P.H. van Belle via samba wrote:
> Naa.. Not needed to reinstall.
> His setup is better then most i see here.
> He could do.
> apt-get remove --autoremove --purge samba winbind
> And reinstall samba, that should be sufficient.
> But stopping samba-ad-dc and removing the files for the /var/{lib,cache}/samba is suffient.
> I do that on every test server.

I was just making sure ;-)

I am going now to the Samba 'join' wiki page to ensure it says 'do not
provision before attempting a join' ;-)


To unsubscribe from this list go to the following URL and read the
instructions: https://lists.samba.org/mailman/options/samba

More information about the samba mailing list