[Samba] Unable to upload printer drivers

Bernhard Dick bernhard at bdick.de
Wed Apr 10 12:00:09 UTC 2019

Hi Louis,

Am 08.04.2019 um 16:05 schrieb L.P.H. van Belle via samba:
> Which drivers? Do you have a link so i can test them myself.
I want to install the Kyocera KX drivers (Version 7.4) . You can 
download the driver at:
> Im running almost same settings and i just installed the samsung universal 3 driver from a win10 X64 pc ( as DOM\Adminstrator)
> This one;
> ?Samsung Universal Print Driver voor Windows  15.9 MB-25.4 MB SamsungUniversalPrintDriver3.exe
> On debian 9, samba 4.9.6
I just installed a fresh debian stable system with the samba 4.9 
packages from your repository, configured samba accordingly to your 
configuration example, set the folder permissions new and also tried the 
Samsung driver. But still no luck.

> My first guess here is, incorrect folder rights, what is in the windows event logs?
If I leave the spoolss versions unchanged I see the error from the 
attached error1.xml.

If I change the spoolss versions to:
spoolss:os_major = 6
spoolss:os_minor = 1
spoolss:os_build = 7601
I receive the errors from error2.xml

I'm currently running Windows 10-1709 on my client machine. I will also 
try it with 1803 to see if that hast some impact.

   Best Regards

More information about the samba mailing list